[Tutorial] Evitati expirarea iOS 7.1 beta 1/2/3

14

Daca sunteti developeri si va jailbreak-uiti device-urile, acest tutorial este facut pentru voi.

De la urmatorul beta (7.1 beta 4) Apple va inchide, cel mai probabil, exploit-urile folosite pentru jailbreak. Dat fiind ca 7.1 e jailbreakable, consider ca e pacat sa nu stati cu ultimul iOS. Problema era ca beta 2 expira pe 27 ianuarie, iar dupa asta, ar fi trebuit sa treceti ori la beta 4 ori la 7.0.4/5, si sa riscati sa pierdeti jailbreak-ul.

Bun, sa trecem la treaba!

UPDATE: Aceasta metoda functioneaza si pe beta 3.

1) Faceti restore si restore from backup la 7.1;

Nota: Daca nu aveti device-ul inregistrat ca developer, iOS-ul nu se va activa. Va pot ajuta eu cu inregistrarea, pagina de contact va asteapta.

2) Faceti jailbreak folosind evasi0n;

3) Instalati afc2add din Cydia si iFunBox/iTools pe PC/Mac;

4) Navigati in System/Library/CoreServices/ si copiati SystemVersion.plist local;

Nota: Puteti descarca de aici SystemVersion.plist-ul modificat, sa il inlocuiti cu cel de mai sus si sa sariti la pasul 8.

5) Pe Mac puteti deschide .plist-ul in TextEdit sau Xcode iar pe Windows puteti folosi utilitarul acesta;

6) Modificati valoarea key-ului ProductBuildNumber si ProductVersion in 11B554a (build-ul de la 7.0.4), respectiv 7.0.4;

7) Stergeti key-ul ReleaseType;

8) Reboot la device si asta e tot.

Optional: Pentru a va asigura ca ati facut totul corect, setati data pe 1 februarie 2014 si faceti reboot la device din nou. Daca totul e bine, device-ul ar trebui sa fie activat. Daca ati gresit ceva, veti vedea ecranul de activare, fara posibilitatea de activare propriu zisa.

14 COMMENTS

      • Vad ca ai scris deja ca merge, eu inca restaurez backup-ul (am 11 pagini de apps), dupa care jailbreak, dupa care iFile, dupa care pot confirma ….

          • Merge brici pe 7.1 beta 3 (eu nu am modificat ProductVersion in 7.0.4, l-am lasat cum era 7.1). Am setat data de 10 martie 2014 si mi-a spus doar ca nu s-a efectuat backup pentru iphone de 8 saptamani :D:D, nu a cerut activare …

  1. Salut , am un iphone 4 cu IOS 7.1.1 codat , eu doresc doar sa i fac o hacktivare sau sa il pot folosi pe post de ipod , exista solutii ? Multumesc

Lasă un comentariu